Reply to this topicStart new topicStart Poll

> 話說,我們有沒打算加裝HTTPS?
耒戈氏
發表於: Sep 15 2019, 00:34  
Quote Post


反潮流才是王道!!
************

發表數: 6,252
所屬群組: 太守
註冊日期: 7-15-2007

活躍:29
聲望:1535


例如let's encrypt? https://letsencrypt.org/
PM
Top
徐元直
發表於: Sep 15 2019, 12:38  評價+1
Quote Post


攤抖首領
************

發表數: 7,889
所屬群組: 君主
註冊日期: 9-18-2003

活躍:64
聲望:4146


很久以前研究過但沒搞懂,當然那時是手動搞openssl沒有現在這些client。

現在不是不能搞,不過這堳雃h軟件都很舊,不知搞完會不會有適配問題。再者因爲hksan沒甚麼特別需要保密的信息,所以除了端對端加密外還有甚麼好處嗎?

本篇文章已被 徐元直 於 Sep 15 2019, 12:39 編輯過


--------------------
......
PMEmail Poster
Top
耒戈氏
發表於: Sep 15 2019, 13:40  
Quote Post


反潮流才是王道!!
************

發表數: 6,252
所屬群組: 太守
註冊日期: 7-15-2007

活躍:29
聲望:1535


軟件方面,應該不會有問題?主要應該是看apache/nginx 之類以及OS吧。話說現在我們用什麼版本的?

主要是考慮如果我們上來的時候,不用HTTPS的話,理論上別人可以在中間竊聽(我知這不是重點),以至把頁面換成別的,或是加插病毒/木馬script之類。(這個才是重點 wacko.gif 雖然我自己沒試過。)
PM
Top
徐元直
發表於: Sep 15 2019, 15:33  評價+1
Quote Post


攤抖首領
************

發表數: 7,889
所屬群組: 君主
註冊日期: 9-18-2003

活躍:64
聲望:4146


試了,這是不是因爲apache版本問題裝不了mod_ssl?


CODE
Resolving Dependencies
--> Running transaction check
---> Package mod_ssl.x86_64 1:2.4.6-89.el7.centos.1 will be installed
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64
--> Processing Dependency: httpd = 2.4.6-89.el7.centos.1 for package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64
--> Processing Dependency: httpd for package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64
--> Finished Dependency Resolution
Error: Package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64 (updates)
           Requires: httpd
Error: Package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64 (updates)
           Requires: httpd-mmn = 20120211x8664
Error: Package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64 (updates)
           Requires: httpd = 2.4.6-89.el7.centos.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@hksan ~]# httpd -v
Server version: Apache/2.2.29 (Unix)
Server built:   Jun 16 2015 01:48:31
[root@hksan ~]#


裝舊版apache是因為新的apache(2.4)似乎用不了舊版php(5.2.17),而php也更新的話論壇會出error。

本篇文章已被 徐元直 於 Sep 15 2019, 15:56 編輯過


--------------------
......
PMEmail Poster
Top
耒戈氏
發表於: Nov 14 2019, 06:43  
Quote Post


反潮流才是王道!!
************

發表數: 6,252
所屬群組: 太守
註冊日期: 7-15-2007

活躍:29
聲望:1535


QUOTE (徐元直 @ Sep 15 2019, 23:33 )
試了,這是不是因爲apache版本問題裝不了mod_ssl?


CODE
Resolving Dependencies
--> Running transaction check
---> Package mod_ssl.x86_64 1:2.4.6-89.el7.centos.1 will be installed
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64
--> Processing Dependency: httpd = 2.4.6-89.el7.centos.1 for package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64
--> Processing Dependency: httpd for package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64
--> Finished Dependency Resolution
Error: Package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64 (updates)
           Requires: httpd
Error: Package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64 (updates)
           Requires: httpd-mmn = 20120211x8664
Error: Package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64 (updates)
           Requires: httpd = 2.4.6-89.el7.centos.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@hksan ~]# httpd -v
Server version: Apache/2.2.29 (Unix)
Server built:   Jun 16 2015 01:48:31
[root@hksan ~]#


裝舊版apache是因為新的apache(2.4)似乎用不了舊版php(5.2.17),而php也更新的話論壇會出error。

論壇軟件有沒新版?會否丟了信息之類的?
PM
Top
徐元直
發表於: Nov 14 2019, 09:59  評價+1
Quote Post


攤抖首領
************

發表數: 7,889
所屬群組: 君主
註冊日期: 9-18-2003

活躍:64
聲望:4146


QUOTE (耒戈氏 @ Nov 14 2019, 14:43 )
QUOTE (徐元直 @ Sep 15 2019, 23:33)
試了,這是不是因爲apache版本問題裝不了mod_ssl?


CODE
Resolving Dependencies
--> Running transaction check
---> Package mod_ssl.x86_64 1:2.4.6-89.el7.centos.1 will be installed
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64
--> Processing Dependency: httpd = 2.4.6-89.el7.centos.1 for package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64
--> Processing Dependency: httpd for package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64
--> Finished Dependency Resolution
Error: Package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64 (updates)
           Requires: httpd
Error: Package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64 (updates)
           Requires: httpd-mmn = 20120211x8664
Error: Package: 1:mod_ssl-2.4.6-89.el7.centos.1.x86_64 (updates)
           Requires: httpd = 2.4.6-89.el7.centos.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@hksan ~]# httpd -v
Server version: Apache/2.2.29 (Unix)
Server built:   Jun 16 2015 01:48:31
[root@hksan ~]#


裝舊版apache是因為新的apache(2.4)似乎用不了舊版php(5.2.17),而php也更新的話論壇會出error。

論壇軟件有沒新版?會否丟了信息之類的?

新版本是有,但是移植很難,因爲私改過太多東西,比如中文修正、聲望系統、防廣告算法、rich text編輯器等等,論壇代碼和db結構都跟原版不同。要重整太花時間了。


--------------------
......
PMEmail Poster
Top
1 位使用者正在閱讀本主題 (1 位訪客及 0 位匿名使用者)
0 位會員:

Topic Options Reply to this topicStart new topicStart Poll

 



[ Script Execution time: 0.0188 ]   [ 12 queries used ]   [ GZIP 啟用 ]